whitespace COMPANY whitespace SERVICES whitespace PRODUCTS whitespace PURCHASE whitespace SUPPORT whitespace CONTACTS whitespace Home whitespace Contact Us whitespace Site Map whitespace
whitespace
SUPPORT
whitespace
FORUM
whitespace
FAQS
whitespace
SUBSCRIPTION
whitespace
REQUEST ON-LINE
whitespace
whitespace

Technical Support Forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
jekkel  
#1 Posted : Thursday, October 21, 2010 7:33:17 PM(UTC)
jekkel
Rank: Newbie

Groups: Registered
Joined: 10/14/2010(UTC)
Posts: 3
Location: Germany

Hi ArtfulBits Team,

the following
Code:

xAxis.setLabelsMode(LabelsMode.NoLabels);
xAxis.setValueType(ValueType.Date);
xAxis.getScale().setInterval(1d, IntervalType.Minutes);

produces some weird gridlines as seen here:
UserPostedImage

The shown labels are custom labels which were manually added. If I use
Code:

xAxis.setValueType(ValueType.Double);
xAxis.getScale().setInterval(60*60*1000d, IntervalType.Double);

everything works fine. But sometimes I want to use monthly data, for which obviously a constant won't work. I want to avoid switching between value types dependent on the gridline interval. As far as I can tell, the problem occurs on IntervalType.Hours and IntervalType.Minutes (btw It looks like there's a typo on IntervalType.Mounth, I guess it should be IntervalType.Months).

Can you reproduce the problem and is there a solution?
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Company | Services | Practices | Technologies | Career | Contacts | Privacy
© 2005-2017 ArtfulBits. All rights reserved.