whitespace COMPANY whitespace SERVICES whitespace PRODUCTS whitespace PURCHASE whitespace SUPPORT whitespace CONTACTS whitespace Home whitespace Contact Us whitespace Site Map whitespace
whitespace
SUPPORT
whitespace
FORUM
whitespace
FAQS
whitespace
SUBSCRIPTION
whitespace
REQUEST ON-LINE
whitespace
whitespace

Technical Support Forum

Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

Options
View
Go to last post Go to first unread
sleytus  
#1 Posted : Tuesday, October 16, 2012 11:28:07 AM(UTC)
sleytus
Rank: Newbie

Groups: Registered
Joined: 10/9/2012(UTC)
Posts: 5

Hello,

We are trying to create multiple legends. We want to be able to control when a series' legend is shown or hidden. However, we are having trouble setting/getting a legend's name. In the code snippet below, strLegendName is always 'null'. What are we doing wrong?

Thanks

Code:
// Create a custom legend that we'll later assign to each series...
ChartLegend legend = new ChartLegend();
legend.setLayoutMode(ChartLegend.LayoutMode.Horizontal);
legend.setAdapter(new ChartLegendAdapter.SeriesItemsAdapter());
legend.setName("custom-legend");
m_oChartView.getLegends().add(legend);

// Sanity check...
for (int i = 0; i < m_oChartView.getLegends().size(); i++)
{
    String strLegendName = m_oChartView.getLegends().get(i).getName();
    Log.d("LegendName: ",strLegendName);
}

[/size]
sleytus  
#2 Posted : Tuesday, October 16, 2012 3:16:31 PM(UTC)
sleytus
Rank: Newbie

Groups: Registered
Joined: 10/9/2012(UTC)
Posts: 5

Hello,

Upon further investigation it seems that multiple legends and binding a legend to a series is broken. If you call series.setLegend("mylegend"), where "mylegend" is a legend that was previously created and added to the chart, then the legend never shows. Even if "mylegend" is specified as a legend in an XML file, it still doesn't work. Calling series.setLegend() using *any* string always results in a hidden legend. Could you please suggest a work-around?

Thanks
Baydalka Volodymyr  
#3 Posted : Tuesday, October 16, 2012 3:20:14 PM(UTC)
Baydalka Volodymyr
Rank: Member

Groups: Registered
Joined: 7/28/2009(UTC)
Posts: 447
Man

Hi,

Thank you for bug-report. We try to upload fix tomorrow.

Best regards,
Volodymyr Baydalka
Andriod development and support team
Baydalka Volodymyr  
#4 Posted : Tuesday, October 16, 2012 5:12:11 PM(UTC)
Baydalka Volodymyr
Rank: Member

Groups: Registered
Joined: 7/28/2009(UTC)
Posts: 447
Man

Hi,

OK, we have fixed this bug. You may download new version : http://www.artfulbits.co...ndroid/try/aicharts.aspx

Best regards

Edited by user Tuesday, October 16, 2012 6:24:21 PM(UTC)  | Reason: Not specified

Volodymyr Baydalka
Andriod development and support team
sleytus  
#5 Posted : Friday, October 26, 2012 12:51:05 PM(UTC)
sleytus
Rank: Newbie

Groups: Registered
Joined: 10/9/2012(UTC)
Posts: 5

Hello,

The fix works great! Thanks very much for your quick response.
Users browsing this topic
Guest
Forum Jump  
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Company | Services | Practices | Technologies | Career | Contacts | Privacy
© 2005-2017 ArtfulBits. All rights reserved.